Crown Vision Center Alton - Partial Outage

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted May 28, 2026 - 07:56 CDT

Identified

Spectrum has been engaged and reports an ongoing node outage affecting services at both 1015 and 1036 in Alton, IL.
Posted May 27, 2026 - 12:56 CDT
This incident affected: Crown Vision Center (Alton).