Oak Forest-Internet Outage
Incident Report for AEG Vision
Resolved
Power issue resolved by practice.
Posted Dec 26, 2024 - 09:10 CST
Investigating
Layer 1 Troubleshooting to commence 12/26
Posted Dec 25, 2024 - 12:02 CST
This incident affected: Memorial Eye Center (Oak Forest).