Kane & Figler Optometry - Partial Outage

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted May 29, 2026 - 15:21 CDT

Investigating

The AT&T circuit is currently down. We are investigating the issue.
Posted May 29, 2026 - 13:39 CDT
This incident affected: ECS of OH (Eye Care Specialties) (Kane & Figler Optometry).