Family Vision Center - Crosby - Internet Outage

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 12:05 CST

Identified

Comcast reported that there's an ongoing wide area power outage that is affecting the server which your service is connected.

There's no available ETTR as it this incident is caused by the severe weather event.

We will provide further updates as soon as they become available.
Posted Jan 28, 2026 - 07:23 CST

Investigating

We are currently investigating this issue.
Posted Jan 28, 2026 - 07:22 CST
This incident affected: Memorial Eye Center (Family Vision Center - Crosby).