Bastrop Family Eye Care - Outage

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 12:57 CDT

Investigating

We are currently investigating this issue.
Posted Oct 03, 2025 - 08:57 CDT
This incident affected: ECS of Central TX (Eye Care Specialties) (Bastrop Family Eye Care).