Bainbridge Vision - ISP Outage

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 07:20 CDT

Update

Current ETR is midnight.
Posted Mar 24, 2026 - 19:03 CDT

Identified

ISP crews are working the issue. No ETR at this time.
Posted Mar 24, 2026 - 15:02 CDT
This incident affected: ECS of WA (Eye Care Specialties) (Bainbridge Vision).