Microsoft 365 Outage

Incident Report for AEG Vision

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 09:06 CST

Investigating

Microsoft is currently experiencing service issues, which may impact MS Office applications and email.
Posted Jan 22, 2026 - 14:35 CST
This incident affected: Services (Office 365 Email).