Carillon Vision Care - Outage

Incident Report for AEG Vision

Resolved

Power and circuits restored.
Posted Jul 28, 2026 - 08:50 CDT

Identified

Power outage in the area due to severe weather. No ETR at this time.
Posted Jul 27, 2026 - 14:56 CDT
This incident affected: ECS of IL (Eye Care Specialties) (Carillon Vision Care).